Back to /openbsd/

If you use OpenBSD you should subscribe to the mailing lists. When you need to patch and what you need to patch will be discussed there likely before anywhere else you will find.
This simple procedure is my current (02/17/2021) habit when I deal with my own systems. Just putting this to compare/replace my other very-old updating page.

doas sysupgrade -nk # get the packages and prepare the upgrade
doas reboot # yes, sysupgrade can handle this, but I like to control this myself
doas pkg_add -uv # update my packages
doas pkg_delete -a # delete old leftover files from packages
doas sysclean # just to see what's there. I always manually review in case my /etc/sysclean.ignore needs to be updated.
doas sysclean | egrep -v '^@' | xargs doas /bin/rm -rf # delete old system remnants
doas sysclean | egrep '^@user' | cut -d ':' -f 1 | awk '{ print $2 }' # confirm users that will be deleted
for USER in $( !! ); do echo $USER; doas userdel $USER; done # yes, use bash shortcut to ref previous line and delete them now confirmed
doas sysclean | egrep -v '^@group' | cut -d ':' -f 1 | awk '{ print $2 }' # confirm groups that will be deleted
for GROUP in $( !! ); do echo $GROUP; doas groupdel $GROUP; done # yes, use bash shortcut to ref previous line and delete them now confirmed
doas sysmerge # manually merge configuration files which have modifications proposed
doas git -C /etc/ add . # yes, I use git to track my /etc/ on every machine
doas git -C /etc/ commit -m 'Performed sysupgrade'
doas git -C /etc/ push origin $(hostname -s) # each machine is its own branch for ease of comparison, etc.